maps.google.com refused to connect

26/05/2021

Suddenly seeing a lot of sites with an error message “maps.google.com refused to connect“. where the Google map should be.

I know Google changed a few things recently to get people using an API when using Google Maps.

Have they tweaked the Google maps settings even more?

Google maps not loading

Google Maps cannot be displayed in a frame

On other sites I am seeing similar but with the error message This content cannot be displayed in a frame where the Google Map should be.

Google maps not loading in frame

Elementor Google Maps Widget stopped working?

A couple of WordPress sites appear to use the Elementor Google Maps Widget does this need updating and do you need a Google API to use the Elementor Google Maps Widget.

Has this happened to your site? – Let me know in the comments below.

Update 26/05/2021 14:40 Elementor Aware of Google Maps problem

Quick update to this post – it looks like it is a problem with the Elementor Google Maps Widget / plugin – They are aware of it and working on it.

Join the conversation

  1. Hi Tarcisio,

    are all the sites using the Elementor Google Maps Widget, some other kind of plugin or are they just manually embedded on the sites?

  2. Me too. They say they just released Elementor v3.2.4 which should fix the issue, but I still could not find it.

  3. YS

    From the plugin update page it has

    “3.2.4 – 2021-05-26
    Tweak: Changed Google Maps widget to use API v3 instead of deprecated v2 (#15090)
    Tweak: Updated Google Fonts list to 05/2021 (#14732, #14536, #13595)
    Tweak: Changed “Missing Header” text for Compatibility tags in System info screen
    Fix: Google Maps widget is not loading due to API deprecation (#15090)
    Fix: Disable Lightbox user preference does not affect the Basic Gallery widget (#12913)
    Fix: Hardened Lightbox capabilities to enforce better security policies”

    It’s still saying it is version 3.2.3 when trying to update though

    Either a mistake or they are still working on it

    Did you install the update?

  4. Hey Guys, It seems that they release an update “ver 3.2.4”. what happens to those who are using elementor ver 2.x on older version of wordpress???

Leave a comment

Your email address will not be published. Required fields are marked *



© 2021 UKSBD - 6 Granby Road, Honington, Shipston-on-Stour, Warwickshire, CV36 5AB - 01608 663759